Running Black & White 2 on Windows 10

Sgt_TX

New member
Joined
Mar 27, 2019
Messages
1
Hello All,
  I have recently installed Black and White 2 and I have slowly been trying to fix it up to where it will run well, with no problems. But I am still having crashing issues.

1.
  Core Application Crash - I'm still getting this crash with all the patches installed and it will happen randomly.
2.
Save File Access Problem/Crash - When I try and access my save files they are not there or some of them will be missing. When I restart the game, they will be there and I can save successfully, but after the first save they will be gone.

These are really my last 2 problems, I somehow fixed the Children ageing problem. I have all three patches installed (Fan Patch 3 is a must have and wonderfully done patch, Thanks to Handsomematt) I have changed the compatibility and I have found out that changing my cores in the affinity hasn't really made my game better or worse. Please help, I have already made it to the last Japanese island through all this crashing and it has been honestly very frustrating. Just trying to seek some advice. Thanks.

Specs:
Windows 7 Ultimate 64 Bit
Intel i5-3570k 3.4Ghz
AMD Radeon HD 7900 series

 

Migra

New member
Joined
Apr 2, 2019
Messages
1
I'm just gonna follow along here. I'm having trouble launching BoTG on my Win 10.

I hope for swift assistance :D And THANK YOU SO MUCH for this amazing file upload :D
 

S_Phil1690

New member
Joined
Jun 25, 2015
Messages
22
venaleaf said:
After installing, everything runs fine but the children aren't growing up..? not sure what to do  :( :help

I had the same problem. Did you install the fan patch? That worked for me.
 

oyyo

New member
Joined
Apr 3, 2019
Messages
3
katshitcrazy said:
So I was able to get Black and White 2 running after downloading the patches.
But I don't understand how to run the Battle of the Gods expansion.
When I downloaded the expansion all I see are reloaded.nfo, rld-botd.bin, and rld-botg.cue files.

Am I suppose to put those somewhere? I downloaded the BOtG patch as well so I'm seeing the BattleOfTheGods.exe but every time I run it I get a "The code execution cannot proceed because binkw32.dll was not found. Reinstalling the program fix this problem."

Any help would be nice.

Good news: I had the same problem and figured out how to get around it. Look in your Black and White 2 folder and copy the binkw32.dll file to the expansion. Basically that file is the "I totally got this legitly" flag.

Bad news: now my game will launch and then never actually appear. Task manager shows it existing for a moment before apparently crashing. I have the fan patch installed and everything; it's quite obnoxious. Let me know if you do or don't have the same issue.

Edit: things I have tried to get it going:
-turning the base game files (without the patch) into an ISO and mounting it.
-having that mounted while I try to play the fan-addition.
-Switching around files like a madman in the folders to make sure the application is able to read everything properly. The answer is yes, but god knows what the issue is.

I had this issue for the base game too, but I believe the fan patch fixed it. My current thought is to make another copy and try to mount all of the files (BoTG.exe, binkw32.dll, reloaded, rld-botg.bin, rld-botg.cue) and see if that'll do anything. I'll let you know how it goes.

If anyone's more computer savvy than me, please help. I'm learning through a lot of trial and error atm.
 

Leviathan

New member
Joined
Apr 10, 2019
Messages
10
I'm having a couple of problems.

Even though the in-game graphical options are all set to high, the textures are all low quality. I've downloaded and installed both official patches and the fan patch, I'm running as admin.
I've tried setting everything in the graphics.config to 3,0,3 but that doesn't seem to do anything. I've also tried running in compatibility mode for XP, Vista, 7, and 8 but that also has no effect.

I'm guessing the game doesn't recognise modern(ish) graphics cards. Does anyone know how I can get it to run the highest graphics settings?

I'm on Windows 10 Pro 64-bit and my graphics card is a Nvidia GeForce GT 640M/Intel HD Graphics 4000 (it's one of those annoying computers that switches to the better graphics card to run certain programs. the game uses the Nvidia card, I don't know if that has any impact).

Edit: Can anyone tell me how I can get the game to run graphics cards it doesn't recognize at 3 0 3 (highest graphical settings)?

 

Reaper93

New member
Joined
May 13, 2019
Messages
2
I actually had a weird bug where my creature would suddenly be 100% grown (size 100%) by the start of land 3 where you first meet the norse leader and creature. This seemed weird so I had to restart a new game.

Edit: I restarted and replayed the game until land 4 again (apparently the first island counts as land 1, but it's the second island facing the Norse) and my creature once again went from being a tiny little thing to being huge. Not gamebreaking, but my poor creature lost his childhood! He was supposed to run around taking shits on houses and throwing boulders at everything... Now he's a big boy..
 

LowChoBro

New member
Joined
Jul 12, 2019
Messages
1
I'm trying to run BW2 on Windows 10.

I downloaded BW2 without issue, as well at Patch 1.1,1.2, and the fan patch.

When I run it, my computer tells me that white.exe is an unknown publisher and asks me if I want to let it make changes (to which I click yes) then nothing happens. Any suggestions?
 

MigX

Member
Joined
Jun 21, 2012
Messages
105
Hello there, i want to know... Well i have black and white 2, plus v1 and v2 patch.

I don't have any issues running the game, even with my high end rig, im talking about a ryzen 1800x, gtx 1080 Ti, 32 gb ram and windows 10 at the latest build, weird thing, i install the game and those two patches and the game runs perfect, even at 4K resolutions, i dont have any texture issues or something weird that makes me install the fan patch, i'm missing something or i just have an strange version of the game?
 

Nusstor

New member
Joined
Mar 19, 2020
Messages
1
:help i got a HUGE problem. Everytime I start a new game (installed it on german) the game just CRASHES so I really hope I can get help because I am looking for this game since 2015! Everyone just told me it was great and I cant get it to run!
 

Drcookie

New member
Joined
Feb 17, 2020
Messages
1
Nusstor said:
:help i got a HUGE problem. Everytime I start a new game (installed it on german) the game just CRASHES so I really hope I can get help because I am looking for this game since 2015! Everyone just told me it was great and I cant get it to run!

I'm having the same problem with mine although mines installed in English if I get mine working I'll be sure to come back and help you

Update:

if you are running Bitdefender you will need to add B&W 2 Core Application to your "Safe Files Access" list
 

Tsuton

New member
Joined
Apr 4, 2020
Messages
1
Hello,

I've download the game from https://www.myabandonware.com/game/black-white-2-bem and I've installed the three patches in order. But I have the old bug therein children don't grow up. Maybe it's the version I have downloaded, but it seems pretty clean except Deviance exe. Any suggestions ?

I don't know I have to use these patches  https://www.gamecopyworld.eu/games/pc_black_and_white_2.shtml because I don't know if they are secure.

Thank you
 

Kye90

New member
Joined
Apr 10, 2020
Messages
1
game runs perfect no issues EXCEPT the children DO NOT AGE, will these patches fix this? i have the game from a different source, ALot of people seem to have same issue with no real confirmed fix on other sites,

i come here and see alot of reports of game crashing... BUT those who get the game to work have the children ageing issue? or is that non existent?
A reply about these patches and this issue would be amazing.
 

N3wb

New member
Joined
Apr 13, 2020
Messages
1
On my part, the children age well, but the game randomly CTD. Haven't seen any solution on this site, did I Miss something? Is there a solution?


Thanks!
 

szumy

New member
Joined
Apr 24, 2020
Messages
3
The solution is downloading other crack file.



Tsuton said:
Hello,

I've download the game from https://www.myabandonware.com/game/black-white-2-bem and I've installed the three patches in order. But I have the old bug therein children don't grow up. Maybe it's the version I have downloaded, but it seems pretty clean except Deviance exe. Any suggestions ?

I don't know I have to use these patches  https://www.gamecopyworld.eu/games/pc_black_and_white_2.shtml because I don't know if they are secure.

Thank you
Kye90 said:
game runs perfect no issues EXCEPT the children DO NOT AGE, will these patches fix this? i have the game from a different source, ALot of people seem to have same issue with no real confirmed fix on other sites,

i come here and see alot of reports of game crashing... BUT those who get the game to work have the children ageing issue? or is that non existent?
A reply about these patches and this issue would be amazing.
 

ItamarGronich

New member
Joined
Jul 8, 2020
Messages
5
HELP! Graphics wont turn to high.
installed 1.1, 1.2 and fanpatch 1.4 and still can't set the graphics to high.

Creature has no fur and no grass on vegitation. no waves.
I have a amd radeon rx 5700 xt
 

andyb1029

New member
Joined
Jul 9, 2020
Messages
2
Hi guys

Just been highlighted to this forum as I dug my old discs out.

Is there and up to date install order with up to date files anywhere so I don't inadvertently download the wrong one? Also will I need the disc again to play after the install process?

Cheers

Andy
 

mush01

New member
Joined
Jul 17, 2020
Messages
1
Hi guys...

I'm trying to install the game on Windows 10, and I've got as far as installing 1.1 and 1.2, but whenever I try to install the fan patch, it just... does nothing? Like nothing happens at all. I'm trying to run it in the B&W folder but it just doesn't actually seem to do anything when I run it. What am I doing wrong?

-edit- I was being an idiot - Windows was blocking the exe because it came from another computer - when I unblocked it in properties it ran fine.
 

baerenserbe

New member
Joined
Aug 20, 2020
Messages
2
Hello,
thank you very much for this great fan patch. I have a original german and english disc version and i have a cracked version by the internet. I installed patch 1.1 and 1.2 and latest fan patch 1.4.
My problem is, if i want to play the Redux Mod 1.71 which needs fan patch 1.3., 80% of my saves are broken (i get stuck after loading the save in the loading screen forever)...
I searched for hours for the older fan patch 1.3, but i cant find it...
please help me, i need the older patch.
My regards.
 

Egerion

Member
Joined
Apr 24, 2010
Messages
9
You don't need v1.3 of fan patch for Redux. You can use v1.4 as well. If you're having issues, i suggest you to check your install. Probably something went wrong while you installing redux or other patches and try to find clean version of B&W2.
 
Top