Got Black and White 2 working in Windows 11 (Fixed) (Can't Save? Check the solution here)

Sonic Wolfe

New member
Dec 21, 2022
So I tried to install BW2 on Windows 11 but it didn't work, despite I did almost nothing different on my Windows 10 machine
The game appears running but crashed once trying to enter a game (e.g. click "new game")
The same behavior observed with BW2 BotG DLC as well...
I also noticed the profile and graphic settings were not saved, but maybe it is because there is no "saved game"?

I tried install 1.1-1.3 patch like I did but also tried installing the 1.42 patch, neither worked. (yes I skipped 1.3 when installing 1.42)
And I attached the dump file created by the 1.42 patch but lack the tool to look or understand the dump...

I also tried following:
Install the game into C: instead of D:
Running game directly instead of using DxWnd
Running game in compatibility mode
Running the game in the administrator mode
Running the game with fps limited to 60

*Interestingly I also installed another Dx 9c game but that worked fine...

here are the specs:
Not working Windows 11 machine
Windows 11 22H2
CPU: Ryzen 7 7700 X
32GB 6000MHz RAM
GPU: RTX 4080
*Ryzen's iGPU is left on but seems 4080 is running the game

Working Windows 10
Windows 10 22H2
CPU: Ryzen 5 3600
16GB 3200MHz RAM
GPU: GTX 970

Thank you in advance for your help!


    170.9 KB · Views: 2
Last edited:
I had figured out why it didn't work

So, in my case, the game launched fine, but the profiles and game setting were not saved if just set the setting and quit the game. Then when attempting to start the game, it loads a little bit before crash to desktop

I suspected something was wrong when the game trying to create a profile, and long behold, there was nothing in the "Documents" Directory.
(You can verify that by search "Run" on you computer and "%Userprofile% \Documents\" or just open explorer, by default there is a quick access link to document)

The particular computer had its documents synced with OneDrive, but for one reason or another, the actual folder name is not in English.
*This is highly possible if your Microsoft account was not registered in an English-speaking country.

So all I did was:
  1. Stop OneDrive Backup (OneDrive -> Settings -> "Back up" tab -> Manage Backup -> Stop back up the Documents)
  2. Create a new folder in the OneDrive, make sure no non-English characters present.
  3. Set the "Documents" directory to the folder you just created in OneDrive (See picture below: Right click "Documents" in quick access works too -> Location Tab -> Change Directory)
  4. Click "Move". If you don't the Windows will ask if you would like to move the existing files, click yes (you may need to log out)
  5. If there are any files left in the original Documents directory, move them over manually.
  6. Re-enable OneDrive Backup (OneDrive -> Settings -> "Back up" tab -> Manage Backup...)
Screenshot 2022-12-24 102311.png

I had verified both BW2 and BoTG worked fine on Windows 11 with DxWnd (for Windowed mode)
Something helpful is set the game to "run as administrator", no need to set single core, or compatibility mode. (Go to where you install the game, find the BW2 excuteable "white.exe", then right click "white.exe", there is a box in the "compatibility" tab)

*If you are using DxWnd v2.05.90 and want to use 16:9 aspect ratio or higher resolutions, go to "Video" tab in DxWnd and set screem resolution to "HDMI". Otherwise, you are limited to 4:3 at max 1600x1200
Last edited: