Workaround for Saving Issue, New Issue Possibly.


New member
Dec 28, 2017
Alright, so my brother and I downloaded Black & White 2, followed internet people and did all that fancy stuff to fix things, and things were good. No glitchy ground, no random crashes, etc.
However, we did have crashes on the occasional save. Not every save, but now and then. We didn't figure out how to fix it exactly, but we did discover a workaround that makes it 10x more liveable.
Save often, and after each save, load immediately. I don't know if this will fix everyone's issues with crashing on save, but it fixed mine for the most part. He said something about memory leaks and that loading reset fancy word stuff, and it worked. As long as I didn't wait too long, my game would not crash on save, which was my only problem at the time.
So that worked for quite a while, until it began to crash on quickload. And I discovered that saving over a file basically deleted it completely, and creating a new save creates nothing. Or if it is creating something, it's not in the game menu to load. So quickload was trying to load a save that doesn't exist, which is crashing the game now. I can still load previous saves, but then I'm back a few steps. I have concluded that this is probably something I did, since this wasn't an issue before. Or it's just B&W2 being angry. I'd be lying if I said I was not considering getting an old computer just to play it, because at this point, that would be much easier!
But, any fixes for a deleting save issue? If I can fix that, I think I can finally have a semi-normal playing experience.
I've just been having this issue lately on the first Aztec land.  I thought it would have something to do with having over 1000 population but considering that's one of the goals of the land I wasn't set on it.

I'll try out this workaround in the mean time and report back any findings.  I've never noticed any issue with memory leaks with this game, and I've left it running for days at a time before (it's very alt-tab friendly it seems and I have 32GB of RAM).  I figured it was an issue with maybe administrator rights for no reason but then it wouldn't have been saving to begin with.
For me, the fan patches (plus compatibility mode AND setting affinity) fixed every single problem in the game bar one:

The exact same issue you pair have. The deleting and crashing on save/load. Nothing offered on the forums has helped make the game playable due to this bug. And its either viewed as unfixable here, or as such a minor issue(cos so few suffer it) that the patch makers aint bothered fixing it. I really hope this can be fixed as i am unable to play the game at all cos of this, and i am utterly dying to play it after so many years.

I have installed as admin, i run as admin, and have followed all instructions and possible fixes offered on the forums to date that i can find.