Running Black & White on Windows 10

Theweird1234

New member
Joined
Jun 19, 2018
Messages
1
So I follow your instructions and on the fan patch I hit the window button yet my game is still minimize and to the top left if I press the full screen button. Please help
 

fixforcrash

New member
Joined
Jun 23, 2018
Messages
1
Hey guys, i made an account to let you know that i managed to fix the pirate version that crashed.

What you do is follow all the steps he has given, however you will install patch 1.2  then his version and run the exe file you get in the end (8460 kb one). You can't install the fan patch first, if you do it will crash at the beginning after you see the intro video. So basically install patch 1.2 then fan version the way he described and run the exe with admin.

After i did this i got past the intro part and could create an account but then it crashed. however the next time i opened the game it worked fine. I'll let you guys know if i have any problems.

DanRage47 said:
There is ONE big issue with all these files. Most Anti-Virus programs, Norton, Avast, Windows Defender, Windows Security Essentials and so on, read almost every file as a virus, malware or otherwise. Bit annoying. To keep them intact and undeleted I've had to store them all in zip files. Otherwise, I LOVE YOU GUYS THAT MADE THIS ALL POSSIBLE!

I do miss having the game in Swedish Language, but I can technically fix that, but that means less addons I think, unless none of the patches have any spoken language, then I may be fine. I can just reinstall otherwise.

As for Swedish Language, I managed to save the installed files from the old computer I had when I first played this game ON ITS RELEASE, LionHead had a studio in Sweden and they re-recorded every line in Swedish. So glad I still have it all saved! If there is anyone that wants it in Swedish though, bear in mind - it is not just the text and spoken words, IT IS THE ENTIRE INSTALLATION FOLDER. I still don't know how to separate any of it. Need help with it.

oh wow, I remember playing the game in swedish and the population constantly screaming " vi vill ha mera mat". Do upload mate :)
 

CharAznable

New member
Joined
Aug 11, 2018
Messages
2
Hello,

I recently started having trouble with B&W1, used to play great on Windows 10.  Now it crashes as soon as it starts to load.  I can see in the event viewer that it's generating exception code 0xc000005.  This appears to be an access issue. 
I have purged the installation, reinstalled vanilla, applied the fan patch.  Same issue fullscreen or windowed.  Tired run as admin, compatibility mode, disabled high DPI and what not but no dice.

Unfortunately I had to manually uninstall the game do to a "catastrophic" error with the uninstaller.  I searched the registry for every entry it may have made and purged them. 

Has anyone seen this?  If so, how did you fix it?

Thanks,
Char
 

MeanPandaKing

New member
Joined
Sep 6, 2018
Messages
1
Hi i cannot install the 1.10 and 1.20 patches.
but i can start the game and it crashes after the first loading screen
 

NostalgicGamer

New member
Joined
Sep 15, 2018
Messages
5
So, I got the game to work (Yay Me!) But I cannot get the in game music to work ( :help). I could hear the music in the outro, intro, and the magical stones in world one. I copied the audio file and placed it in my C: drive as suggested but nothing works. I want to continue playing tonight but I also want the music to work. If I could get a reply soon that would be much appreciated, please and thank you.
 

Matt

Administrator
Staff member
Joined
Aug 28, 2005
Messages
196
NostalgicGamer said:
So, I got the game to work (Yay Me!) But I cannot get the in game music to work ( :help). I could hear the music in the outro, intro, and the magical stones in world one. I copied the audio file and placed it in my C: drive as suggested but nothing works. I want to continue playing tonight but I also want the music to work. If I could get a reply soon that would be much appreciated, please and thank you.

All you need to do is copy the Audio folder from the disk to the game directory, it will prompt you to merge the folders.

2es6cRv.png
 

NostalgicGamer

New member
Joined
Sep 15, 2018
Messages
5
I did that. I checked between my windows and your example, yet I hear no music. Could my skipping the 1.2 patch be part of it? Otherwise I am out of options. Thank you for your help so far!
 

wistful

New member
Joined
Jan 14, 2018
Messages
3
For anyone that wants to play Creature Isle on Windows 10, you'll indeed require the NO-CD patch, as Handsome Matt mentioned earlier in the thread.

You can download it from here:

http://www.gameburnworld.com/gp/gamefixes/blackandwhitecreatureisle.shtml

If you want to play in 1920x1080 open up Regedit and go to HKEY_CURRENT_USER\Software\Lionhead Studios Ltd\Black & White\BWSetup and find the ScreenH and ScreenW keys, change the value of ScreenH to 438 for 1080 and the value of ScreenW to 780 for 1920.

It's working fine so far a few hours in!  :)
 

Gaires

New member
Joined
Sep 25, 2018
Messages
1
Hello.

I have been trying to install the game for few hours now, but everytime i run the installer i get this message. https://imgur.com/JokXkaj
I'm using windows 10 64bit and legit "sold out" copy of the game. I'm the administration, have been using the installer as administrator, tried to disable UAC and have deleted all the registery nodes.
Funny thing is also that the installer creates that folder and installs ikernel.exe into it, and installshield starts running in the background.

Edit: Nevermind, i got the game working by installing and patching it on my laptop, then simply transferring the files to my desktop.
 

[email protected]

New member
Joined
Oct 20, 2016
Messages
4
CharAznable said:
Hello,

I recently started having trouble with B&W1, used to play great on Windows 10.  Now it crashes as soon as it starts to load.  .../...
Unfortunately I had to manually uninstall the game do to a "catastrophic" error with the uninstaller.  I searched the registry for every entry it may have made and purged them. 
Has anyone seen this?  If so, how did you fix it?

Thanks,
Char

I have had that problem when I installed in other than default, was doing fine in default, but not in other location. I could not install patches and I could not uninstall either. The only way I could get rid of it was by doing a system restore to before the date I installed B&W1. 
 

DPistolKing

New member
Joined
Nov 23, 2018
Messages
1
Hello, I have this problem where I can't see the game at full screen correctly, I can see more of the left upper corner than everything else, it looks like this:


https://drive.google.com/open?id=1nRl5WK6432Uo65d95skE9OQD252kPRfS    (I don´t know how to attach an image sorry).


I don´t know what could cause this problem, but please help me. I'm on a windows 10 laptop :(
 

Matt

Administrator
Staff member
Joined
Aug 28, 2005
Messages
196
You probably have the resolution set too high or something similar, try changing it to various ones lower then your actual laptop resolution.

If all else fails windowed mode should work well, I realize it's not as nice as fullscreen though.
 

Quil the Great

New member
Joined
Feb 6, 2019
Messages
1
:help I made this game start okay, using the tips from this post and some others (I.E. installing to a location other than default) on Windows 8, but the frame rate is abysmal! I tried a fix (put a file called DDRAW.DLL into the install folder), and it made a negligible difference. It is sort of playable but rather annoying, so if anyone has any help, it would be much appreciated! The hardware is an intel Core 2 Duo and 2GB of memory. Thanks!
-Quil
 

roelu

New member
Joined
Mar 1, 2019
Messages
1
Hi,

Running W10 with everything set up to the initial post's specifications (with no addons), the game will start to load, give me the Lionhead/Intel intro, allow me to pick a name and symbol (if no profile is found already), and then cut straight to a screen that asks

  • Please choose from one of the following options:
    • Start the game normally
    • Skip straight to the Creature select
    • Skip all of the Creature tutorial
    • Keep your old Creature
    After picking any option, I see the God Hand for a second and then the program promptly closes. Event viewer gave this error log:
Code:
Faulting application name: runblack.exe, version: 1.0.0.1, time stamp: 0x3d0ecf82
Faulting module name: LHMultiplayerR.dll, version: 0.0.0.0, time stamp: 0x3cd2b1cf
Exception code: 0xc0000005
Fault offset: 0x00021c87
Faulting process id: 0x36f4
Faulting application start time: 0x01d4d045c935acf2
Faulting application path: C:\Program Files (x86)\Lionhead Studios Ltd\Black & White\runblack.exe
Faulting module path: C:\Program Files (x86)\Lionhead Studios Ltd\Black & White\LHMultiplayerR.dll
Report Id: 89fec651-10a9-4fc8-a130-61e6b788ce25
Faulting package full name: 
Faulting package-relative application ID:

I have no intention to play multiplayer so I don't need a working LHMultiplayerR.dll, but I'm not sure how to work around this myself. Any ideas?
 

Matt

Administrator
Staff member
Joined
Aug 28, 2005
Messages
196
The event viewer log is really helpful actually, I'll investigate - from my knowledge though LHMultiplayer.dll relies on some really really old modem APIs in Windows that are probably removed, I'll look into it and confirm it if so, I think I'll be able to patch it too.
 

Baz786

New member
Joined
Mar 23, 2017
Messages
7
Handsome Matt, could make a patch so we as the B&W faithful can play Creature Isle with launch problems on Windows 10. I can get B&W, B&W2, Battle of the Gods to work with your great patches. Just Creature |sle is the problem.

 

Piothr

New member
Joined
Mar 11, 2019
Messages
1
Thank You so much for the tutorial, I finally managed to get BW1 to work, thanks to you.

However, I ran into a problem, which I managed to solve (I'm not in any way an expert, so I consider myself simply lucky)

My problem was that the patches (1.1 and 1.2) didn't want to install on my computer. A "catastrophic failure" error came up and I couldn't do anything about it. The 1.4 patch installed correctly, but the game kept crashing as soon as it was launched.

The problem I had came out to be caused by the InstallShield Installer.

My solution was:
1. Uninstalling the game (by deleting the folders and registry entries mentioned in the beginning of the tutorial)
2. Moving all folders from C:\Program Files (x86)\InstallShield Installation Information to a folder on Desktop (just in case i screw something up)
3. Installing the game according to the tutorial, BUT Changing the name of the folder where the game is installed to C:\Games\BW1 (I have read in another tutorial that special characters and spaces can make the game not install correctly).

Did the trick for me, I hope it helps!
And once again, Thank you Handsome Matt for helping me to bring back childhood memories!
 
Top